Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => iMX233 => Topic started by: elamre on April 10, 2015, 04:45:34 pm

Title: Disable audio
Post by: elamre on April 10, 2015, 04:45:34 pm
Hello,
I'm not using the audio on my board, and it doesnt seem to work either. I very often get the message:

sgtl5000 0-000a: Failed to get mclock: -2
i2c 0-000a: Driver sgtl5000 requests probe deferral


i have no clue what this means, I found the directory with the sgtl driver but am not quite sure how to disable or remove it (So i can avoid this message). I found out that the sgtl is indeed the audio codec.

Any help or ideas are appreciated :)
Title: Re: Disable audio
Post by: swahren on April 11, 2015, 11:07:42 am
Please describe which Olimex board and Kernel version you are using.
Title: Re: Disable audio
Post by: elamre on April 11, 2015, 03:14:00 pm
I'm sorry for not including that.

I'm using the imx maxi, and have the newest version from the arch linux kernel,
http://archlinuxarm.org/platforms/armv5/olinuxino

I dont have access to the board right now sadly enough, so i can't give exact details
Title: Re: Disable audio
Post by: swahren on April 11, 2015, 03:46:42 pm
From my understand the i.MX23 doesn't have a sgtl5000 only the i.MX28.

There are patches to get the audio chip on the i.MX23 working:

https://github.com/ITserve/imx23-audio
Title: Re: Disable audio
Post by: elamre on April 11, 2015, 04:21:31 pm
That would explain the message then :)
I have no need for sound, can i simply remove it in some way?