Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => iMX233 => Topic started by: bbt on November 14, 2012, 01:51:56 PM

Title: [SOLVED] Quotas
Post by: bbt on November 14, 2012, 01:51:56 PM
I'm using an Olinuxino MAXI.
uname -a :
Linux 2.6.35-6-ARCH+ #1 PREEMPT Fri Aug 31 14:22:01 EEST 2012 armv5tejl GNU/Linux

Extract from /boot/config-2.6.35-6-ARCH+ :

Extract of /etc/fstab :
/dev/sda1   /home/windows   ext4   grpjquota=quota.group,jqfmt=vfsv1,grpid,nosuid,noexec,nod
ev   0   0

Result of dmesg | grep quot :
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: grpjquota=quota.group,jqfmt=vfsv1,grpid

Problem :
When I try "quotaon /home/windows" I get :

quotaon: using /home/windows/quota.group on /dev/sda1 [/home/windows]: No such process
quotaon: Quota format not supported in kernel.

And if I try to overpass the limits, quota are effectively inactives...

Did anyone succeed to use quota ? What is wrong in my case ?
Thanks a lot.

Title: Re: Quotas
Post by: bbt on November 14, 2012, 05:10:37 PM
In fact, it seems the problem was due to a difference between the boot sector I took here :
The tarball given here is corrupted and the only thing I could use is the boot sector :
dd if=/Archlinux/Linux-alarm-2.6.35-6-ARCH.img of=/dev/sdb1

So, I used the tarball from ArchlinuxARM.

I had to use the 1st boot sector, because the one given in the 2nd didn't work (no boot) on a new SD card :
dd if=/mountpoint/boot/oli-*.sb of=/dev/sdx1 ibs=512 seek=4 conv=sync,notrunc

But doing this, some functionalities didn't work correctly.

So I tried to create the boot sector from the 1st site and to overwrite it with the 2nd, thinking that the seek=4 clause needs a pre-initialised sector...

Miracle... Olinuxino boots and quota work !!!

I hope this explanations can be usefull...