Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => iMX233 => Topic started by: flavigny on November 07, 2012, 04:35:34 pm

Title: Trying Netgaer WG111v3 Usb-wifi dongle on ArchLinux
Post by: flavigny on November 07, 2012, 04:35:34 pm
 :(Hello,

I run (now): http://archlinuxarm.org/platforms/armv5/olinuxino

Seeing a folder "rtl818x", I tried my old Wg711v3

lsmod see it:
[root@alarm usbpo]# usb 1-1.2.3: USB disconnect, address 8
usb 1-1.2.3: new high speed USB device using fsl-ehci and address 9
usb 1-1.2.3: New USB device found, idVendor=0846, idProduct=4260
usb 1-1.2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2.3: Product: NETGEAR WG111v3
usb 1-1.2.3: Manufacturer: Manufacturer_NETGEAR
usb 1-1.2.3: SerialNumber: 001E2AB7AE2C

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]

...

but insmod finish in error:


[root@alarm net]# cd wireless/
[root@alarm wireless]# cd rtl818x/
[root@alarm rtl818x]# insmod rtl8187.ko
rtl8187: Unknown symbol ieee80211_free_hw (err 0)
rtl8187: Unknown symbol ieee80211_alloc_hw (err 0)
rtl8187: Unknown symbol ieee80211_register_hw (err 0)
rtl8187: Unknown symbol ieee80211_generic_frame_duration (err 0)
rtl8187: Unknown symbol ieee80211_tx_status_irqsafe (err 0)
rtl8187: Unknown symbol wiphy_rfkill_set_hw_state (err 0)
rtl8187: Unknown symbol ieee80211_queue_delayed_work (err 0)
rtl8187: Unknown symbol wiphy_rfkill_stop_polling (err 0)
rtl8187: Unknown symbol eeprom_93cx6_multiread (err 0)
rtl8187: Unknown symbol wiphy_rfkill_start_polling (err 0)
rtl8187: Unknown symbol ieee80211_unregister_hw (err 0)
rtl8187: Unknown symbol ieee80211_frequency_to_channel (err 0)
rtl8187: Unknown symbol ieee80211_rx_irqsafe (err 0)
rtl8187: Unknown symbol eeprom_93cx6_read (err 0)
rtl8187: Unknown symbol ieee80211_rts_duration (err 0)
Error: could not insert module rtl8187.ko: Unknown symbol in module
[root@alarm rtl818x]#


How are defined those symbols ?
I have probably missed a step?

Regards.
PO.