New Page 1

Introduction

The MAXQ2000 is a low-power, high-performance 16-bit RISC microcontroller based on the MAXQ™ architecture. It includes support for integrated, in-system-programmable flash memory and a wide range of peripherals including an LCD driver supporting up to x4 multiplexed displays. The device can operate at a maximum of either 14MHz (VDD > 1.8V) or 20MHz (VDD > 2.25V). The MAXQ2000 has 32kWords of flash memory, 1kWord of RAM, three 16-bit timers, and one or two universal synchronous/asynchronous receiver/transmitters (UARTs). Flash memory aids prototyping and low-volume production. The microcontroller core is powered by a 1.8V supply, with a separate I/O supply for optimum flexibility. The MAXQ2000 is ideally suited for battery-powered, portable applications such as blood glucose monitoring, medical instrumentation, environmental data logging, and industrial control.

The MAXQ-P2000 Development board is designed to evaluate MAXQ2000-RAX processor. It has the following features:

  • 2xRS232 Connectors, one can be used for code bootloader

  • JTAG Connector for programming with MAXQ-JTAG.

  • SPI Connector - to connect with devices, which support SPI interface protocol.

  • 1-Wire Connector for communication with 1-Wire device

  • replaceable high frequency crystal 20 MHz on socket and soldered low frequency 32768 Hz crystal

  • two buttons on ports with interrupts

  • Reset button

  • power and status leds

  • Two on-board power supply voltage regulators, one with adjustable +1.8-2.2-2.5V for the core and one +3.3V for the GPIOs

  • On board Li-io 3V battery holder for power supply backup (note: the power supply form the battery doesn't supply the RS232 driver, so RS232 communication is possible only when external power supply is applied)

  • board can take power from JTAG connector if PWR_JTAG jumper is closed and JTAG can supply power (MAXQ-JTAG-USB have target power feature)

  • power jack connector for AC/DC power supply

  • extension headers for each uC pin on 0.1" row header

  • prototype area with GND and 3.3V bus

The purpose of this guide is to describe MAXQ-P2000 Development board.

Board | MAXQ-P2000
Hardware details | Describes the hardware peripherals in detail
Revision | 2.0 / 01.11.2005

Copyright (c) OLIMEX Ltd. All rights reserved


Picture

This is picture of MAXQ-P2000 Development board.

Board MAQX-P2000

Copyright (c) OLIMEX Ltd. All rights reserved


P2000


P2000 Board


MAXQ P2000 Hardware description

Peripherals

Unit | Description
RS232 Connector (RS232_ICSP) | RS232 DB9 Female connector for MAXQ2000 UART0.
RS232 Connector (RS232) | RS232 DB9 Female connector for MAXQ2000 UART1.
JTAG Connector | 2x5 0,1" step connector for programming with MAXQ-JTAG.
1-Wire Connector | Interface to 1-Wire device connected to OW_IN (pin 46) and OW_OUT (pin 45)
SPI Connector | 6 pins connector for devices which use SPI protocol.
Buzzer | Buzzer audio output connected to P6.0 (pin 43) and P6.1(pin 44), which are outputs for Timer 1
Buttons | Button BUT1 connected to interrupt ports - P3.6 (pin 20) and Button BUT2 connected to interrupt ports P3.7 (pin 21)
Leds | Status led (LED) connected to P3.5 (pin 19) and power supply indicator.

Technical characteristics

Parameter | Description
Voltage Supply | min 6.0V DC, max 12.0V DC min 4.5V AC, max 9.0V AC
Supply current | Active Current Mode ~ 16mA Power Management Mode ~ 1,4mA Stop Mode ~ 0,04mA (40uA)
CPU | MAXQ2000-RAX
Crystals | Q1 - 20MHz HF crystal Q2 - 32,768 KHz clock crystal
Board dimensions | 100x80 mm (4.0x3.2")
PCB | FR-4, 1.5 mm (0,062"), green soldermask, white silkscreen component print
Operating Temperature | form 0ºC to 70ºC

JTAG Connector

Pin / Name | Connected to: | Functionality
1 - TCK | PIN 29 | P4.0 / TCK / INT8
2 - GND | GROUND | -
3 - TDO | PIN 32 | P4.3 / TDO
4 - VREF | VCC | -
5 - TMS | PIN 31 | P4.2 / TMS
6 - RST | PIN 33 | RESET
7 - - | not connected | -
8 - VCC_IN | + 5V IN | -
9 - TDI | PIN 30 | P4.1 / TDI / INT9
10- GND | GROUND | -

VCC-IN can be used to supply power to MAXQ-P2000 board from MAXQ-JTAG-USB or compatible. The Voltage supplied by MAXQ-JTAG-USB is 5V up to 100 mA taken from the USB port.

RS232 Connector (RS232_ICSP)

Pin / Name | Connected to: | Functionality
1 - CD | not connected | -
2 - RXD | PIN 52 | P7.0 / TXD0 / INT14
3 - TXD | PIN 53 | P7.1 / RXD0 / INT15
4 - RTS | not connected | -
5 - GND | GROUND | -
6 - DSR | not connected | -
7 - RTS | not connected | -
8 - CTS | not connected | -
9 - RI | not connected | -

RS232 doesn't work when only Li-ion battery is connected.
Max communication baud rate supported by MAXQ2000-RAX is 500 kbps, maximum baud rate with MAX3232 driver on board is 250 kbps.

RS232 Connector (RS232)

Pin / Name | Connected to: | Functionality
1 - CD | not connected | -
2 - RXD | PIN 37 | P5.3 / TXD1 / INT11
3 - TXD | PIN 36 | P5.2 / RXD1 / INT10
4 - RTS | not connected | -
5 - GND | GROUND | -
6 - DSR | not connected | -
7 - RTS | not connected | -
8 - CTS | not connected | -
9 - RI | not connected | -

RS232 doesn't work when only Li-ion battery is connected.
Max communication baud rate supported by MAXQ2000-RAX is 500 kbps, maximum baud rate with MAX3232 driver on board is 250 kbps.

SPI Connector

Pin / Name | Connected to: | Functionality
1 - GND | GROUND | -
2 - SSEL | PIN 38 | P5.4 / _SS
3 - MOSI | PIN 39 | P5.5 / MOSI
4 - MISO | PIN 41 | P5.7 / MISO
5 - SCLK | PIN 40 | P5.6 / SCLK
6 - VCC | VCC | -

Max communication speed supported by MAXQ2000-RAX is 1/2 the system clock for master mode operation and 1/8 the system clock for slave mode operation.

1-Wire Connector

Pin / Name | Connected to: | Functionality
1 - 1W | PIN 45 and PIN 45 | P6.2 / T2B/ OW_OUT and P6.3 / T2 / OW_IN via jumper J_OW
2 - GND | GROUND | -

1W have on board pullup to 3.3V.

Jumpers

Jumpers | Position | Description
Jumper E_BUZZ |  | Buzzer is not connected.
 |  | Buzzer connected to P6.0 (pin 43) and P6.1(pin 44), which are outputs for Timer 1
Jumper J_OW |  | OW_OUT is connected to 1W connector and can be used as general purpose GPIO.
 |  | OW_IN connected to OW_OUT and MAXQ 1W interface controller can be used.
Jumper 1.8V/2.2V |  | Core Supply Voltage is 1.8 V
 |  | Core Supply Voltage is 2.5 V
 |  | Core Supply Voltage is 2.2 V
Jumper EXT/BAT |  | External power supply (Power jack or JTAG Connector)
 |  | Battery power supply


Links

1. Maxim-Dallas web site

MAXQ2000 tools & training | http://www.maxim-ic.com/MAXQ
MAXQ2000 datasheets | http://pdfserv.maxim-ic.com/en/ds/MAXQ2000.pdf
MAXQ2000 user guide | http://www.maxim-ic.com/products/microcontrollers/pdfs/MAXQUG.pdf http://www.maxim-ic.com/products/microcontrollers/pdfs/MAXQ2000_UG.pdf
MAXQ2000 forum | http://discuss.dalsemi.com/

2. Olimex-MaxQ boards discussion forum

http://groups.yahoo.com/group/maxq-olimex/
http://www.olimex.com/dev

3. IAR Systems EW-MAXQ C compiler and debugger

http://www.iar.com/Products/?name=EWMAXQ

4. Rowley associates CrossWorks for MAXQ C compiler and debugger

http://www.rowley.co.uk