New Page 1

Introduction

The MAXQ2000 is a low-power, high-performance 16-bit RISC microcontroller based on the MAXQ™ architecture. It includes support for integrated, in-system-programmable flash memory and a wide range of peripherals including an LCD driver supporting up to x4 multiplexed displays. The device can operate at a maximum of either 14MHz (VDD > 1.8V) or 20MHz (VDD > 2.25V). The MAXQ2000 has 32kWords of flash memory, 1kWord of RAM, three 16-bit timers, and one or two universal synchronous/asynchronous receiver/transmitters (UARTs). Flash memory aids prototyping and low-volume production. The microcontroller core is powered by a 1.8V supply, with a separate I/O supply for optimum flexibility. The MAXQ2000 is ideally suited for battery-powered, portable applications such as blood glucose monitoring, medical instrumentation, environmental data logging, and industrial control.

The MAXQ-H2000 Development is a header board for MAXQ2000-RAX processor. It has the following features:

  • JTAG connector

  • 20 Mhz (on socket) and 32 768 Hz oscillator crystal

  • Two on-board power supply voltage regulators, one with adjustable +1.8-2.2-2.5V for the core and one +3.3V for the GPIOs

  • PWR_JTAG allow board to be power supplied by the JTAG (if MAXQ-JTAG-USB is used)

  • power supply filtering capacitors

  • extension headers for each uC pin on 0.1" row header

  • PCB: FR-4, 1.5 mm (0,062"), green soldermask, white silkscreen component print

  • Dimensions: 47x47 mm (1.8x1.8")

  • space between the pin rows: 43.18 mm (1.7")

The purpose of this guide is to describe MAXQ-H2000 Development board.

Board | MAXQ-H2000
Hardware details | Describes the hardware peripherals in detail
Revision | 2.0 / 01.11.2005

Copyright (c) OLIMEX Ltd. All rights reserved


Picture

This is picture of MAXQ-H2000 Development board.

Board MAQX-H2000

Copyright (c) OLIMEX Ltd. All rights reserved


H2000


MAXQ- H2000 Board


MAXQ H2000 Hardware description

Peripherals

Unit | Description
JTAG Connector | 2x5 0,1" step connector for programming with MAXQ-JTAG.

Technical characteristics

Parameter | Description
Voltage Supply | min 6.0V DC, max 12.0V DC min 4.5V AC, max 9.0V AC
CPU | MAXQ2000-RAX
Crystals | Q1 - 20MHz HF crystal Q2 - 32,768 KHz clock crystal
Board dimensions | 47x47 mm (1.8x1.8")
PCB | FR-4, 1.5 mm (0,062"), green soldermask, white silkscreen component print
Operating Temperature | form 0ºC to 70ºC

JTAG Connector

Pin / Name | Connected to: | Functionality
1 - TCK | PIN 29 | P4.0 / TCK / INT8
2 - GND | GROUND | -
3 - TDO | PIN 32 | P4.3 / TDO
4 - VREF | VCC | -
5 - TMS | PIN 31 | P4.2 / TMS
6 - RST | PIN 33 | RESET
7 - - | not connected | -
8 - VCC_IN | + 5V IN | -
9 - TDI | PIN 30 | P4.1 / TDI / INT9
10- GND | GROUND | -

VCC-IN can be used to supply power to MAXQ-P2000 board from MAXQ-JTAG-USB or compatible. The Voltage supplied by MAXQ-JTAG-USB is 5V up to 100 mA taken from the USB port.

Jumpers

Jumpers | Position | Description
Jumper 1.8V/2.2V |  | Core Supply Voltage is 1.8 V
 |  | Core Supply Voltage is 2.5 V
 |  | Core Supply Voltage is 2.2 V
Jumper PWR_JTAG |  | Disable JTAG power supply.
 |  | Enable board to be power supplied by the JTAG (if MAXQ-JTAG-USB is used)


Links

1. Maxim-Dallas web site

MAXQ2000 tools & training | http://www.maxim-ic.com/MAXQ
MAXQ2000 datasheets | http://pdfserv.maxim-ic.com/en/ds/MAXQ2000.pdf
MAXQ2000 user guide | http://www.maxim-ic.com/products/microcontrollers/pdfs/MAXQUG.pdf http://www.maxim-ic.com/products/microcontrollers/pdfs/MAXQ2000_UG.pdf
MAXQ2000 forum | http://discuss.dalsemi.com/

2. Olimex-MaxQ boards discussion forum

http://groups.yahoo.com/group/maxq-olimex/
http://www.olimex.com/dev

3. IAR Systems EW-MAXQ C compiler and debugger

http://www.iar.com/Products/?name=EWMAXQ

4. Rowley associates CrossWorks for MAXQ C compiler and debugger

http://www.rowley.co.uk